Aggregate Ethernet

From Juniper JSRX Wiki

Jump to: navigation, search

Aggregate Ethernet (ae) is a way to aggregate ethernet interfaces (duh!). In laymans terms, you can bundle multiple links together to function as a single logical high bandwidth link.

Contents

Basic Config

First thing we need to do to configure ae interfaces is define how many we are going to configure (don't worry, you can overshoot this without any problems).

chassis {
    aggregated-devices {
        ethernet {
            device-count 5;
        }
    }
}
set chassis aggregated-devices etherenet device-count 5

Next we need to define the logical ae interfaces as we would a physical link

interfaces {
    ae0 {
        aggregated-ether-options {
            minimum-links 2;
        }
        unit 0 {
            family inet {
                address 192.168.78.5/24;
            }
        }
    }
    ae1 {
        aggregated-ether-options {
            minimum-links 4;
        }
        unit 0 {
            family inet {
                address 192.168.36.13/24;
            }
        }
    }
}
set interfaces ae0 aggregated-ether-options minimum-links 2
set interfaces ae0 unit 0 family inet address 192.168.78.5/24
set interfaces ae1 aggregated-ether-options minimum-links 4
set interfaces ae0 unit 0 family inet address 192.168.36.13/24

Now that we have the ae interfaces defined, we need to bundle physical interfaces to them.

interfaces {
    ge-0/0/0 {
        gigether-options {
            802.3ad ae0;
        }
    }
    ge-0/0/1 {
        gigether-options {
            802.3ad ae0;
        }
    }
    ge-0/0/2 {
        gigether-options {
            802.3ad ae0;
        }
    }
    ge-0/0/3 {
        gigether-options {
            802.3ad ae1;
        }
    }
    ge-0/0/4 {
        gigether-options {
            802.3ad ae1;
        }
    }
    ge-0/0/5 {
        gigether-options {
            802.3ad ae1;
        }
    }
    ge-0/0/6 {
        gigether-options {
            802.3ad ae1;
        }
    }
}
set interfaces ge-0/0/0 gigether-options 802.3ad ae0
set interfaces ge-0/0/1 gigether-options 802.3ad ae0
set interfaces ge-0/0/2 gigether-options 802.3ad ae0
set interfaces ge-0/0/3 gigether-options 802.3ad ae1
set interfaces ge-0/0/4 gigether-options 802.3ad ae1
set interfaces ge-0/0/5 gigether-options 802.3ad ae1
set interfaces ge-0/0/6 gigether-options 802.3ad ae1

Now that we have the basic setup to get the ae interface up and running, you will need to treat it like a standard interface by putting it into a security zone, configure host-inbound-services, etc...

LACP

Link Aggregation Control Protocol is a protocol that handles error checking, misconfiguration checking, and general stability control on Link Aggregation Groups (LAGs). By default LACP is not enabled but is not specifically required for an ae interface to function. All you need to do to configure LACP is to turn it on under the ae interface

There are two LACP modes and that is Active and Passive. Active means that that link can activly send out LACP packets when negotiating a link. Passive means it waits for LACP packets from the other side before negotiating.

interfaces {
    ae0 {
        lacp {
            active;
        }
    }
}
set interfaces ae0 lacp active


LACP tuning

LACP load balances packets across links based on a hash of the packet. Generally, you can define if you want the hash to consist of layer 2 or layer 3 information or both. This can be done with the following config options

forwarding-options {
    hash-key {
        family inet {
            layer-3;
            layer-4;
        }
    }
 }
 set forwarding-options hash-key family inet layer-3 
 set forwarding-options hash-key family inet layer-4 

Hidden

If you need further granularity on what exactly gets included in the LACP hashing then here are some hidden commands

forwarding-options {
    hash-key {
        family inet {
            layer-3 {
                destination-address;
                incoming-interface-index;
                protocol;
                source-address;
            }
            layer-4 {
                destination-port;
                source-port;
                type-of-service;
            }
        }
    }
 }
 set forwarding-options hash-key family inet layer-3 destination-address
 set forwarding-options hash-key family inet layer-3 incoming-interface-index
 set forwarding-options hash-key family inet layer-3 protocol
 set forwarding-options hash-key family inet layer-3 source-address
 set forwarding-options hash-key family inet layer-4 destination-port
 set forwarding-options hash-key family inet layer-4 source-port
 set forwarding-options hash-key family inet layer-4 type-of-service
Personal tools